Dropper seat post won’t drop

I have a new Norco Sight that I bought this winter that I have very few rides on because I have been riding my Fat bike.
The Sight has a dropper post that worked when I bought it but I have never used it seeing I have not been riding anywhere that dropping the post was needed
Today I could have used it several times but it won’t drop because the leaver doesn’t pull the cable something is not moving. I tried YouTube for answers but none of the videos addresses this problem. Does anyone have any ideas on what could be the issue?

And why am I jimk on my iPad and Spin on my iphone

Did you ride it on a wet day and store it outside… line maybe frozen up?

What is the brand? I’ve had a the trans x dropper on my New Norco sight not work properly after I rode in the pouring rain. I solved the issue by lubricating the dropper cable with tri-flo. It took a while for it to work it’s way in and free the cable up.

No stored clean in door’s
It was + 6 today in Halifax

Does the lever move or is it stuck?

  • RAD is written on it
    I had one ride at Gore where at the end of the day the sun had warmed up the 100 yards of trail to the parking area enough that it was a bit greasy that was the only time it ever got wet
    And I doubt if anything got in the cable

No the lever doesn’t move

Did you lower the seatpost (not using the dropper function but the seat collar)? Maybe the cable is pinched or the mechanism is bottomed out?

https://www.instagram.com/tv/CK9cUaaFE0K/?igshid=y9y4kqd3i30x

Watched that earlier YouTube doesn’t have any videos I can find on this problem
I could take it apart and see why the cable won’t move but because it is brand new I will just do the hour long drive and have the shop I bought it from look into the situation
Thanks for the comments

hey Jim - Pull the post out a little from inside the frame, if the post bottoms out near the kink in the frame it will jam up the leverage point.

Thanks I’ll try that

Didn’t work and there was lots of room either way

1 Like

Did you take the whole post out yet? Disconnect from cable and actuate the lever manually carful not to damage it. This should tell you if it’s the post or the cable itself. If it’s the post look for anything blocking from moving, otherwise it could be internal. Could try letting some of the air out, if the actuator can move at all. It’s possible running at max recommended pressure is causing extra forces somewhere and making problems. Just a few ideas. Definitely a weird issue. Good luck.

Thanks Ryan
If it was old I would try everything but because it is new I am going to take it to the shop I bought it from
It did work and I haven’t used it and it hasn’t been dropped or abused in anyway it’s been sitting in my basement pretty much since I bought it
Did you see your clip in the news?

2 Likes

Is there a link to the clip? I caught it but wouldn’t mind sharing it here.